Расширенный поиск  

Новости:

Автор Тема: Читать всем! К вопросу о NM3..  (Прочитано 3860 раз)

0 Пользователей и 1 Гость просматривают эту тему.

ekx71

  • Легенда
  • ******
  • Спасибо: 37 раз(а)
  • Оффлайн Оффлайн
  • Сообщений: 2.744
  • ОЗТ: 152482
  • г.Стрежевой регион 70
Читать всем! К вопросу о NM3..
« : Июнь 29, 2012, 00:13:59 »

Снова приходится возвращаться к вопросу об Атласе в формате NM3..
 Используя ответы многоуважаемых старожилов ресурса, сразу определяемся: любые сборки Атласа RUSNAVI в формате псевдоNM3 в настоящее время корректно работают только на версиях выше НН_5.0.0.778 и ниже 5.0.4.ххх!
P.P.S.: В последних версиях 5-ого Навитела (во всех вышедших после 5.0.3) произошли изменения в работе с дорожным графом, поэтому все не официальные карты (в том числе и наши бетки) стали работать не корректно (по слухам из-за плохих продаж официальных карт, но не знаю на сколько это правда). Причём это не баг это специально сделанные изменения! Писал об этом много кратно, но почему-то всё равно часто спрашивают об этом на форуме. Так что если вы слышите "возьмите левее", "правее" и такой-то "съезд" на каждом перекрёстке, то посмотрите прежде всего какая у вас версия, если старше 5.0.3, то дело в этом, выход только один поставить Навител 5.0.3, в нём всё работает корректно!

 Создание контейнера псевдоНМ3 подразумевает под собой предварительную индексацию Атласа в формате NM2 с отдельным роутингом, при этом создается индексный файл, который формируется версией НН, в которой проводилась индексация. С этим и связаны рекомендации использовать для версий до 5.0.3.70 сборку от ekx71, а выше 5.0.3.70 - сборку от spacer. Это не значит что сборки не будут работать в других версиях, но такая вероятность есть. На работу контейнера псевдоNM3 оказывают влияние много факторов, одним из которых является соответствие индексного файла контейнера псевдоNM3 Вашей версии НН, чем он ближе,тем вероятность нормальной работы выше (об этом пишет и сам создатель инструмента для псевдоНМ3: лучший вариант - использовать собственный индекс!).

В настоящий момент на сайте представлены 3 типа контейнеров псвдоNM3:
- От spacer: рекомендован для версий НН 5.0.3.70 и выше (индекс от НН_5.0.3.411)
- От ekx71: рекомендован для версий НН 5.0.0.778 - 5.0.3.70 (индеск от НН_5.0.0.778)
- Экспериментальные (рекомендации пишет создатель)

Основой для создания контейнера служит сборка Атласа с отдельным роутингом, созданные автоматически и выложенные в зоне трекеров, поэтому писать отдельно об ошибках в Атласе псевдоНМ3 не следует, пишем в соответствующих темах.. Для желающих создать контейнер самостоятельно вот инструмент, а  здесь исходные данные.
« Последнее редактирование: Январь 20, 2013, 00:42:11 от ekx71 »
Записан
Lenovo IdeaTab A2107+SG Tab4

Navitel_5.0.3.99\9.3|CG\GN8 And4.0.3\4.4.2
 
 

Страница сгенерирована за 0.019 секунд. Запросов: 21.